Chapter 1: A Quick Tour of Adobe ImageStyler

This interactive tour introduces you to key features of Adobe ImageStyler and takes about an hour to complete. For detailed instructions on the ImageStyler features introduced in this tour, see online Help or the index in this user guide.

You’ll use ImageStyler to create the graphics for two Web pages. Here’s the page you’ll create first.

The finished Web page

Setting up ImageStyler

You’ll start by arranging the ImageStyler toolbox and palettes.

1 Copy the Tour folder in the Adobe ImageStyler folder onto your desktop. Later in the tour, you’ll drag Adobe Photoshop and Adobe Illustrator files from the folder into ImageStyler.

2 Double-click the Adobe ImageStyler icon to start the application, or in Windows, choose Adobe ImageStyler from the Start menu. If you need help, see the Introduction in this user guide for instructions.

ImageStyler opens with a new empty document in its image window. The white space in the middle of the window is the canvas on which you compose. By default, ImageStyler also displays a toolbox and several palettes in stacked groups.

If you don’t see the toolbox or any one of the palettes, you can choose it from the Window menu.

Drawing and transforming objects

The Web page you’re composing will have a button bar for navigating to other Web pages. You’ll create the bar yourself, starting by drawing a rectangle.

1 Click the rectangle tool (□) in the toolbox to select the tool.

2 On the canvas, drag diagonally with the rectangle tool to draw a rectangle of any size. Don’t worry about the color (black, by default).

Next, you’ll transform the rectangle to an exact size by scaling it.
All objects in ImageStyler—geometric ones you create with the drawing tools, text created with the type tool, even bitmap images placed from image files—can be transformed the same way. In fact, all objects in ImageStyler can be modified in the same ways. Moreover, all objects always remain editable.

3 Click the Transform tab to display the Transform palette. (If the palette isn’t visible on-screen, choose Window > Transform. A check mark next to the menu command indicates that the palette is open on-screen.)

4 In the Transform palette, enter 90 in the W text box and 475 in the H text box and press Enter (Windows) or Return (Mac OS). This makes the rectangle 90 pixels wide by 475 pixels high. You can also resize the rectangle by dragging one of its selection handles.

If typing in the palette doesn’t resize the rectangle, you probably deselected the rectangle after drawing it. Just click inside the rectangle to reselect and enter the dimensions again.

Note: If the 90-pixel by 475-pixel rectangle is taller than the canvas, choose Edit > Canvas Size and change the canvas back to its default height, 500 pixels.

Adding a 3D effect

Next, you’ll use a Photoshop image as a texture for the navigation bar and then add a 3D effect to it. Bitmap images can be imported into ImageStyler, where they can be left as separate objects or applied to any object as a texture.

1 Open the Tour folder on your desktop, positioning it so that you can still see the canvas.

2 Drag the Photoshop file IS_01.psd from the Tour folder onto the rectangle; when the selection border for the rectangle appears, release the mouse button. The image appears inside the rectangle, cropped to the size of the rectangle.

Now you’ll add a 3D effect to the rectangle.

3 Click the 3D tab to bring the palette to the front (or choose Window > 3D).

4 Using the pop-up menu at the top of the 3D palette, choose Emboss. Make sure that the rectangle is still selected.

You can choose from four automated 3D effects in Adobe ImageStyler—cutout, embossing, beveling, and ripples—that you can apply to any layer of an object.

5 Drag the Depth and Softness sliders to the left and right to try different effects.
6 Move the pointer inside the selected rectangle. Notice that the pointer turns into the hand tool (عبارة)، which you use to move objects.

7 Drag the rectangle so that it’s within a few millimeters of the top right corner of the canvas.

**Styling and arranging objects**

Next, you’ll create buttons for the navigation bar using one of the ImageStyler predefined styles.

1 Use the rectangle tool (عبارة) to draw a button-size rectangle 65 pixels wide and 40 pixels high, to the left of the navigation bar. You can view the Transform palette to check the dimensions as you draw the rectangle.

2 With the rectangle selected, choose Edit > Make Alias. Making an alias is like copying, but with a difference you’ll see in a moment.

3 Choose Edit > Make Alias again. Now you have three identical rectangles.

4 Choose Windows > Properties or click the Properties tab to display the Properties palette.

5 With one of the buttons selected, choose Ellipse from the pop-up menu in the Properties palette. Because you are working with aliases, not copies, all three rectangles change into ellipses. Any change you make to an original or its alias is reflected in both. You can, however, unlink the alias from the original object.

Now you’ll apply a style to the ellipses. Styles give you an easy way to apply a set of attributes—such as a fill, multiple layers, and 3D and distortion effects—to any object in ImageStyler. Styles can be applied to objects such as the rectangle you created, text, and even bitmap images. You can use existing ImageStyler styles, create your own styles, or modify styles at any time.

6 Click the Styles tab to display the palette. (If the palette isn’t open on-screen, choose Window > Styles.) The Styles palette provides three separate views of the available styles. You’ll switch to a view that includes the name of the style.
7 Position the pointer on the triangle in the upper right corner of the Styles palette, click or press the mouse button to display the Styles pop-up menu, and choose Preview View.

8 With one of the ellipses still selected, choose the Magnifying Glass style from the list, and click Apply. Because the objects are aliases, all three buttons change, even though only one is selected.

A style can contain one to five layers (each with its own color or effect) that take the shape of the object to which you apply the style. Any style you apply to an object affects all of its layers.

9 Drag the selected button onto the center of the bar.

10 Then drag the other buttons into position, roughly positioning them in the top and bottom third of the bar and centering them, as shown in the following illustration. You don’t have to position the buttons exactly, because you’ll adjust them in the next steps.

11 Hold down Shift and click all three buttons to select them all.

12 Choose Object > Align > Horizontal Centers to line the buttons up by their center points.

13 Choose Object > Distribute > Vertical to position them equidistant from each other in a vertical line in the image.

**Adding text**

Next you will label the buttons, adding a style to the text, just as you did with the buttons.

1 Select the type tool (T) and click an empty spot on the canvas. The Type Tool dialog box appears.
2 In the text area of the Type Tool dialog box, type DRESS in all caps. This text also appears where you clicked in the composition.

Note: If you don’t see the text on the canvas, move the dialog box to the side.

3 Choose a font from the Font menu in the dialog box. We chose a wide sans serif font, Lucida Bold.

4 Type 16 in the Size text box in the dialog box.

5 Choose the centered text option by clicking on the center alignment button. Then click OK.

7 Drag the text onto the top button, centering it visually.

Your three labels will have the same style, so you’ll duplicate the first label to create the other two.

8 Choose Edit > Duplicate twice. You duplicate rather than make an alias so that changing the text of one label won’t change the text of the others.

9 Drag the duplicate button labels on top of the other two buttons.

Now you’ll add a style to the text.

6 In the Styles palette, choose Interior glow and click Apply.

Next you’ll change the text of two of the labels.

10 Double-click the label in the second button, type SPORT over DRESS in the Type Tool dialog box, and click OK.

11 In the same way, type FUN in the third button.

At this point you could link the three buttons to separate pages on dress shoes, sport shoes, and fun shoes. For now, you’ll skip that step and continue with the page layout.
Working with layers

ImageStyler objects are constructed in layers, and you can work on them a layer at a time. Next you’ll create a stylized title for your composition and enhance it with a layering effect.

1. Select the type tool (T) and click in the canvas.
2. Type LE SHOE in the Type Tool dialog box.
3. In the Type Text dialog box, choose any font and size. (We chose Lucida Regular 18-point.) Click OK to add the text to your canvas and close the dialog box.
4. Click the Properties tab to display the palette. (If the palette isn’t open on-screen, choose Window > Properties.)

The Properties palette displays information about the text. ImageStyler changes the contents of the Properties palette to display information appropriate to the type of object you’ve selected. The font size (T) text box in the palette shows the point size you chose, 18.

5. With the LE SHOE text still selected, hold down Shift and drag any corner selection handle (except the upper right corner) outward until the point size displayed in the Properties palette is about 76.

(Dragging the text box’s upper right corner rotates the text, not resizes it. The rotate icon appears when you position the pointer over the upper right corner.)

6. In the Styles palette, select Mercury and click Apply.
Any object in ImageStyler, even text and bitmap images, can be created with up to five object layers, with different effects applied to each layer. You'll now apply a different style to an object layer.

7 Click the Object Layers tab to display the palette in the front of its palette group.
   (If the palette isn’t visible on-screen, choose Window > Object Layers.)

8 In the Object Layers palette, click the glow layer to make it active.

The Object Layers palette lists all layers that make up an object, starting with the topmost layer.
When you create an object in ImageStyler, it consists of at least one layer. You can add up to four more layers to the object, all sharing the same shape but with different attributes.

Next, you’ll move the text object’s glow layer, to create a shadow effect.

9 Select the layer-offset tool (･) in the toolbox.

10 On the canvas, drag the text to move the glow layer. Drag the glow layer slightly down and to the right.

You can also use the X Offset and Y Offset sliders in the Layer palette to move the glow layer horizontally and vertically. You can use the Layer palette to improvise with other layering possibilities—fill, width, or softness. Just select a layer and experiment.

11 Click the selection tool in the toolbox. Then move LE SHOE into position at the top of the canvas, centered in the space to the left of the navigation bar.

Creating image maps

An image map is an image that works like a button bar, with different parts on the image linked to different Web pages.

First you’ll place a drawing created in Adobe Illustrator under the LE SHOE heading. This will be the background for the image map. Then you’ll add shoe images that will be the links.

1 Choose File > Place, locate the Tour files folder on the desktop, and select the file IS_02.ai

2 Click Open to place the file on the canvas. Notice that the color of the artwork matches the foreground color selected in the toolbox.
Placing a file on the canvas this way is equivalent to dragging it from its folder, as you did with the Photoshop file you used for the fill in the navigation bar.

3 Using the selection tool, position it over the square so that the tool changes to a hand. (The selection tool changes to the hand tool when positioned over an opaque part of the graphic.)

4 Then drag the square to center it under LE SHOE.

Now, you’ll place three Photoshop files from the Tour folder, each with a different kind of shoe, on the square.

5 Click away from the artwork to make sure that nothing is selected. (Selection handles appear around any selected object.)

Dragging an object or image onto a selection replaces it.

6 Place the sport shoes in the Photoshop file IS_03.psd, also in the Tour folder, on the canvas. Either use the File > Place command as you just did, or drag the file from the folder.

7 With the selection tool ( ), and the shoes selected, hold down Shift and drag a corner selection handle inward to make the sport shoes smaller. Look at the illustration of the finished Web page at the beginning of this tour to get an idea of the size.

8 Move the shoes into position, as in the final composition. Click away from the shoe artwork to deselect it.

9 Place the file IS_04.psd from the Tour folder on the canvas, and then resize and position the image to match the final composition shown at the beginning of the tour; then deselect the artwork.
Repeat the previous step for the IS_05.psd file, positioning it in the lower left corner of the square.

With the dress boot (IS_05.psd) still selected, click the Transform tab to display the Transform palette. (If the palette isn’t visible on-screen, choose Window > Transform.)

Drag the rotation control in the lower left of the Transform palette clockwise to rotate the boot slightly, so that its toe is pointing upward. You can fine-tune the rotation by number. We positioned it at 348 degrees. You may also want to reposition the boot a little, after rotating it, using the selection tool.

Click away from the boot to deselect it.

Now you’ll link the dress shoes to a Web page.

Select the dress sandals.

Click the Web tab to display the Web palette. (If the palette isn’t visible on-screen, choose Window > Web.)

Type http://www.adobe.com (or any Web address) in the URL text box of the Web palette. When you later export this composition as an HTML page, the dress shoes illustration will link to the home page of the Adobe Web site. To complete the image map, you could link each shoe image to a different Web page.

Adding shapes

This Web page is part of a sequence of pages, so it needs Next Page and Previous Page buttons. You’ll select shapes for the buttons by using the Shapes palette.

Click the Shapes tab to display the palette. (If the palette isn’t visible on-screen, choose Window > Shapes.)

Position the pointer on the triangle at the upper right corner of the Shapes palette, click or press the mouse button to display the Shapes menu, and choose Preview View.

The Shapes palette, like the Style and Textures palettes, lets you choose three separate views of the available styles.
3 In the Shapes palette list, choose “Arrow, spiral left” and click Place to add the shape to the canvas.

4 Drag the button so that it’s centered below the image map you created earlier, but does not touch any other bounding box (the outline that defines the boundaries of an object). Later in the tour, you’ll add a Javascript rollover action to the spiral. If the shapes overlap, the rollover won’t work as intended.

To create a second spiral arrow, you’ll make a copy of the left spiral and flip it.

5 With the spiral still selected, choose Edit > Copy and then Edit > Paste to create a copy of the spiral.

6 Choose Object > Transform > Flip Horizontal to flip the spiral so that its arrowhead points right.

7 Drag the right spiral so that it’s next to the left-pointing spiral and centered beneath the image map, in the position illustrated.

8 Shift-click to select both spiral arrowheads. Then use the Style palette to apply the Mercury style to them.

## Adding a rollover action

When you roll the mouse pointer over a link on a Web page, it’s helpful if the link reacts, such as changing color or shape, to show that it’s a link. ImageStyler uses JavaScript to create these rollover actions.

On the page that you’ve been working with, the spiral arrowheads are designed to be links to other pages. Now you’ll add a Javascript action to the right spiral.

1 In ImageStyler, select just the right spiral.

2 Click the JavaScript tab to display the palette or choose Window > JavaScript.

In the palette, notice that JavaScript action is set to noAction.

3 Click the New Action button (\[\]) at the bottom of the JavaScript palette. This creates a JavaScript action called onMouseOver.

Now you’ll alter the spiral arrowhead to make it change when the pointer is over it.
4 Click the Color tab to display the Color palette. (If the palette isn’t visible on-screen, choose Window > Color.)

5 Position the pointer on the arrow at the top right corner of the Color palette and choose RGB View from the pop-up menu. The RGB color model lets you choose a color with red, green, and blue values ranging from 0 to 255.

6 Change the layer’s color by dragging one or more of the R, G, and B sliders. You can also click or drag in the color bar to select a color.

We selected bright red by moving the R slider all the way to the right, to 255, and the G and B sliders all the way left to 0.

Changing an object’s color is one of the simplest and most effective ways to indicate a JavaScript action. You can also rotate or scale an object, or combine a transformation with a color change.

You could link the buttons to the previous and next pages in the sequence. For the tour, you’ll skip that step.

To make the JavaScript action work, you must export it to a Web page with AutoSlice or AutoLayout selected. You’ll perform that step after completing the page.

---

**Adding a background**

You’ll add a background to your page to complete the Web page layout.

1 Click the background color selection box at the bottom of the toolbox.

2 Click the Textures tab to display the Textures palette. (If the palette isn’t visible on-screen, choose Window > Textures.)

3 Position the pointer on the triangle at the top right of the Textures palette, and choose Preview View from the pop-up menu.

This action deselects any object currently selected and applies the next command or option you select to the entire background of the composition.
In the Textures palette list, choose Yellow Brick and click Apply. The texture fills the entire background. If you select an object before applying the texture, it fills only the object’s selected layer.

Saving and exporting

Your ImageStyler composition is complete, but not yet exported to a Web page. To use the composition in a Web page, you must export the ImageStyler artwork in a Web graphic format. You can export an ImageStyler document as a GIF (Graphics Interchange Format), JPEG (Joint Photographic Experts Group), or PNG-Indexed (Portable Network Graphics) or PNG-Truecolor file.

It’s important, however, to save the composition in ImageStyler format before exporting it, so that you can edit any of the objects later. Saving a file in ImageStyler format saves all the layers in objects along with all the separate editable attributes.

1 In ImageStyler, choose File > Save As and save the composition as Leshoe.ist.

2 Choose Window > Export to display the Export palette.

In the Export palette, you choose the export file format, set image quality, and select other export options.

3 Select Active Preview in the Export palette and notice the number to the right. This is the document size in bytes.

With Active Preview on, you can make adjustments to the export settings (or make other edits to the composition) to see how the exported image will look and to preview the export file’s size.

4 From the pop-up menu at the top of the Export palette, choose JPEG.

You can reduce the file size by reducing image quality. With JPEG files, reducing quality increases the amount of data discarded during compression.

5 Adjust the image quality by dragging the Quality slider left or right. Notice how the file size decreases or increases in response.

6 Select Reduce Chroma. This option further reduces file size, by reducing the amount of color information in the exported image.
You can export the composition as one image file, or export its components—slices—as separate image files. ImageStyler divides the composition depending on the relationship of the individual objects. Any objects that are grouped or touch (including their bounding boxes) become a single image.

You can also export slices so that they appear on the Web page in a layout that approximates the layout in the ImageStyler composition. ImageStyler automatically creates an HTML file that provides the layout, and references the sliced files.

7 Choose AutoLayout from the pop-up menu next to the Make Page option.

8 Choose File > Export As and save the selection as leshoe.html. ImageStyler automatically saves the composition as separate JPEG files.

9 Start your Web browser and open the file leshoe.html.

ImageStyler has approximated the ImageStyler composition by generating a custom HTML table with cells the right size and position for the objects in your composition.

10 Try out the rollover action you assigned to the right spiral button by positioning your pointer over it. If you are connected to the Internet, you can click the right spiral button to display the Adobe Web page.

Replacing text on an HTML page

In this part of the tour, you’ll make an HTML file more interesting by replacing its text headings with images. The image headings combine the text from the HTML file’s heading with a styled ImageStyler object.

You’ll work with another page in the Le Shoe Web project. But first you’ll take a look at the HTML page that you’ll be modifying.

1 Launch your Web browser, if necessary.

2 In your Web browser, open the IS_06.html file, located in the HTML folder in the Tour folder.

HTML file

The text “Feeling Dressy?” is tagged with the H1 HTML tag—a first-level heading—and the two underlined phrases are tagged with the H4 tag (fourth-level headings). You want these headings to have some pizazz, more than they have here.
A Quick Tour of Adobe ImageStyler

3 In ImageStyler, open the file IS_07.ist.

![ImageStyler file](image)

These are the objects you’ll use to style the images for the HTML headings.

4 Make sure that the Web palette is displayed. If necessary, click its palette tab or choose Window > Web.

5 Using the selection tool ( ), click to select the larger sample text at the top of the composition.

6 In the Web palette, choose H1 from the Replace menu.

7 Click to select only the sample text of the smaller heading. Do not select the rectangle. Even though just the sample text is selected, ImageStyler will use the style of the sample text and the style and shape of other overlapping or touching objects when creating the image files.

8 In the Web palette, choose H4 from the Replace menu.

9 Choose File > Batch Replace HTML. This command exports the HTML to your Web page.

10 Locate the Tour folder. Double-click IS_06.html, the page you just viewed, to replace the header styles in it with the ImageStyler styles.

11 In your Web browser, reload the page IS_06.html.

As you can see, the headings are a lot more intriguing. Notice that the image headings also contain the background of the ImageStyler composition. This guarantees that shadow effects look correct. To complete this page, you would use your HTML editing application to apply the same background image to the Web page.

![Web page](image)

Later, if you decide to update the look of your Web page, you can use different styles and replace the image headings with new files.

Congratulations, you’ve finished the ImageStyler tour! You’re ready to begin using ImageStyler with real Web projects, to give them visual richness, texture, and style.